Does my old bar work with the 2014 and 2015 Cabrinha 1x Overdrive bar

Posted by Administrator on 12/1/2014 to Support videos
For 2014, Cabrinha kiteboarding introduces the 1X security system for all kites. Some riders wondered if the 2014 and 2015 Cabrinha bar is compatible with 2011 2012 or 2013 kites. This video demonstrates why it is not compatible and why all 2014 and 2015 should use a 2014 or 2015 Cabrinha bar which is the 1X system. 

Notice how, upon activating the QR 1 the kite doesn't flag or self land.

    

If you own a 2014 or 2015 Cabrinha kite, you will need a 1x 2014 or 2015 bar in order for the safety features to work properly including full shutdown. The cabrinha race bar is the only bar fully compatible with all systems including ids and 1x from 2011, 2012, 2013, 2014 and 2015. 

For more information contact us at 1-800-590-9314. 

Article by Juan Carlos Morales 
comments powered by Disqus